您的瀏覽器似乎不支援JavaScript語法,但沒關係,這裡的JavaScript語法並不會影響 到內容的陳述, 如需要選擇字級大小,IE6請利用鍵盤按住ALT鍵+ V → X → (G)最大 (L)較大(M)中(S)較小(A)小,來選擇適合您的文字大小, 而IE7或Firefox瀏覽器則可 利用鍵盤 Ctrl + (+)放大(-)縮小來改變字型大小,如需要回到上一頁可使用瀏覽器提 供的 Alt+左方向鍵(←) 快速鍵功能,列印可使用瀏覽器提供的(Ctrl+P)功能。
News Detail Banner
> 首頁 > 漏洞公告

Apache Struts 2.3.X系列版本中的Showcase應用程式存在允許攻擊者遠端執行任意程式碼之漏洞(CVE-2017-9791),請儘速確認並進行修正

內容說明:

Apache Struts 2是一個開放原始碼的Java EE網路應用程式的Web應用框架。
該漏洞主要是在Apache Struts 2.3.X系列版本啟用Struts 2 Struts 1外掛(struct2-strust1-plugin.jar)環境下,Showcase應用程式(struct2-showcase.war)呼叫struct2-strust1-plugin時,攻擊者利用傳遞含有惡意字串的內容,造成可遠端執行任意程式碼。

影響平台:

Apache Struts 2.3.X的版本

建議措施:

1.請確認網站主機是否使用Apache Struts 2 的Web應用框架,若有使用則可再透過網站主機目錄中的「WEB-INF\lib\」資料夾內的Struts.jar檔確認當前使用的版本。
2.請確認網站主機是否使用Apache Struts 2的Showcase應用程式,路徑:\struts2.3.x\apps\struts2-showcase.war。
3.如所使用的Apache Struts為上述(2.3.X)受影響之版本,則請更新官方網頁或官方Github所釋出最新之Apache Struts 2.5.10的版本。
4.若無使用的需求,請關閉Showcase應用程式。

參考資料:

1.https://meterpreter.org/cve-2017-9791-apache-struts2-s2-048-remote-code-execution-vulnerability/
2.https://cwiki.apache.org/confluence/display/WW/S2-048

Publish Date
2017/7/10 9:18:10